Scheduled Maintenance - Loop - 14th April 2025
Scheduled for April 14, 2025 at 11:00 AM – 12:18 PM
Affects
Loop
Under maintenance from 11:00 AM to 12:18 PM
Completed
April 14, 2025 at 12:18 PMCompleted
April 14, 2025 at 12:18 PMThanks for your patience, Loop is now up and running!
Don't forget to close your browser and reopen Loop again to ensure the update fully applies to your connection!
In progress
April 14, 2025 at 11:00 AMIn progress
April 14, 2025 at 11:00 AMMaintenance is now in progress
Planned
April 14, 2025 at 11:00 AMPlanned
April 14, 2025 at 11:00 AMWe’ll be performing scheduled maintenance to keep things running smoothly and implement some new features.
Loop will be temporarily unavailable during this time.